Cara Mencegah Brute Force Attack Pada Mikrotik




Mencegah Brute Force Attack
Mencegah Brute Force Attack

Cara Mencegah Brute Force Attack Pada Mikrotik

Cara Mencegah Brute Force Attack Pada Mikrotik. Seperti yang telah kita ketahui bersama bahwasanya keamanan selalu berbanding terbalik dengan kenyamanan dalam konteks jaringan komputer. Contoh yang paling sederhana adalah ketika kita ingin terhubung pada sebuah jaringan wifi, maka kita lebih nyaman dengan jaringan wifi yang tanpa password karena tidak perlu repot-repot mengisikan password terlebih dahulu untuk bisa terhubung ke wifi tersebut dan langsung bisa berselancar ke internet.

Nah tentunya dari contoh diatas juga memiliki resiko dalam keamanan di jaringan wifi tersebut dimana bisa saja orang-orang yang tidak bertanggung jawab juga masuk ke dalam jaringan wifi kita dan memanfaatkan jaringan kita untuk kegiatan-kegiatan ilegal. Atau bisa saja orang-orang yang tidak bertanggung jawab tersebut melakukan packet sniffing sehingga menimbulkan kerugian di sisi pengguna.

Untuk itulah diperlukan keamanan dalam sebuah jaringan. Keamangan jaringan komputer sendiri terdiri dari kebijakan-kebijakan dan langkah-langkah pencegahan dalam jaringan agar sebuah jaringan dapat dipantau dan dicegah dari akses-akses yang tidak sah, modifikasi jaringan, dan penyalahgunaan jaringan komputer sehingga merugikan pengguna maupun sumber daya lainnya yang ada dalam sebuah jaringan komputer tersebut.

Baca Juga : Cara Blokir Youtube di Mikrotik

Serangan Dalam Jaringan Komputer

Dalam konteks jaringan komputer, sebuah serangan dalam jaringan komputer adalah segala upaya untuk menghancurkan, mengekspos, mengubah, menonaktifkan, mencuri, atau mendapatkan akses atau menggunakan aset secara tidak sah.

Jenis-jenis serangan dalam sebuah jaringan komputer sendiri sangat bervariasi. Namun serangan dalam jaringan komputer yang biasanya sering terjadi diantaranya adalah :

  1. Footprinting
  2. Malicious Documents and/or Links
  3. Suspicious Activity
  4. DNS Cache Poisioning
  5. Denial of Service
  6. Backdoors
  7. Fingerprinting
  8. Brute Force Attack
  9. Shellsocks
  10. SQL Injection
Firewall

Nah, untuk menahan serangan-serangan dalam jaringan tersebut biasanya dibutuhkan Firewall. Firewall sendiri adalah sebuah sistem keamanan jaringan yang berfungsi untuk mengontrol dan memonitor lalu lintas jaringan yang masuk dan lalu lintas jaringan yang keluar berdasarkan aturan-aturan keamanan jaringan yang sebelumnya telah ditentukan.

Firewall setidaknya memiliki dua buah konsep yaitu Eksklusif dan Inklusif. Eksklusif berarti Firewall mengizinkan seluruh lalu lintas jaringan komputer kecuali lalu lintas jaringan komputer yang cocok dengan aturan yang telah ditentukan sebelumnya. Sedangkan Inklusif maksudnya adalah Firewall hanya memperbolehkan masuk lalu lintas jaringan yang dianggap cocok dengan aturan yang telah ditentukan sebelumnya, sedangkan lalu lintas jaringan yang selain itu secara otomatis akan terblokir.

Pada router Mikrotik sendiri sudah mempunyai Firewall dengan klasifikasi firewall yang diantaranya adalah :

  • Alamat MAC (MAC Address) sumber
  • IP Address dan tipe address (broadcast address, local, multicast, unicast)
  • Port atau Port range
  • IP Protocol
  • Protocol options (ICMP, TCP, IP Options)
  • DSCP byte
  • Isi paket (packet content)
  • Ukuran paket (packet size)
  • dan masih banyak lagi
Brute Force Attack

Brute force attack merupakan sebuah serangan pada jaringan komputer dimana penyerang melakukan percobaan kata sandi atau frasa dalam sebuah kata sandi dengan harapan kata sandi tersebut merupakan kata sandi yang benar. Penyerang melakukan percobaan secara sistematis terhadap kemungkinan-kemungkinan kata atau frasa sandi sampai sandi yang benar dapat ditemukan.

Lalu bagaimana cara untuk mencegah brute force attack pada router Mikrotik ? Ada beberapa cara yang dapat dilakukan.

Mengganti Service Port

Silahkan ganti service port pada router mikrotik anda dengan port yang telah ditentukan. Secara default service port pada router mikrotik adalah Telnet (Port 23), SSH (22), FTP (21), Winbox (8291). Jika anda hanya membutuhkan akses winbox saja, anda bisa menonaktifkan port lain selain port winbox. Untuk melakukan hal tersebut anda bisa masuk pada menu IP > Services.

IP Services Mikrotik
IP Services Mikrotik

Harap catat port yang baru sehingga anda tidak lupa konfigurasi yang telah anda ubah karena itu akan diperlukan ketika anda akan login kembali ke dalam router anda melalui winbox. Untuk login dengan winbox setelah mengubah portnya anda bisa menuliskan IP Address:port ke dalam kotak winbox anda. Perhatikan gambar dibawah ini :

Baca Juga : Cara Memblokir Situs Tertentu Dengan Mikrotik

Winbox Login
Winbox Login

Selain mengganti port, untuk mencegah brute force attack juga bisa dilakukan konfigurasi pada firewaal router mikrotik anda. Buka Terminal pada router mikrotik anda dan ketikkan konfigurasi berikut ini :

ip firewall filter
add chain=input protocol=tcp dst-port=21,22,23,8291,8728 src-address-list=bruteforce_blacklist action=drop \ comment=”drop brute forcers” disabled=no
add chain=input protocol=tcp dst-port=21,22,23,8291,8728 connection-state=new \ src-address-list=bruteforce_stage3 action=add-src-to-address-list address-list=bruteforce_blacklist \ address-list-timeout=10d comment=”” disabled=no
add chain=input protocol=tcp dst-port=21,22,23,8291,8728 connection-state=new \ src-address-list=bruteforce_stage2 action=add-src-to-address-list address-list=bruteforce_stage3 \ address-list-timeout=1m comment=”” disabled=no
add chain=input protocol=tcp dst-port=21,22,23,8291,8728 connection-state=new src-address- list=bruteforce_stage1 \
action=add-src-to-address-list address-list=bruteforce_stage2 address-list-timeout=1m comment=”” disabled=no
add chain=input protocol=tcp dst-port=21,22,23,8291,8728 connection-state=new action=add-src-to- address-list \
address-list=bruteforce_stage1 address-list-timeout=1m comment=”” disabled=no

Atau bisa juga dengan menerapkan rule konfigurasi yang membatasi 10 kali percobaan salah yang masuk melalui FTP dengan script berikut ini :

/ip firewall filter
add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop comment=”drop ftp brute forcers”
add chain=output action=accept protocol=tcp content=”530 Login incorrect” dst-limit=1/1m,9,dst-address/1m
add chain=output action=add-dst-to-address-list protocol=tcp content=”530 Login incorrect” address-list=ftp_blacklist address-list-timeout=3h

Demikian lah tips untuk mencegah brute force attack, semoga artikel ini bermanfaat.




Be the first to comment

Leave a Reply

Your email address will not be published.


*


This site uses Akismet to reduce spam. Learn how your comment data is processed.